Windows Beta - Unable to start Rekord Buddy



Same Here!

Same here.

same here.

I purchased the Rekordbuddy license and installed it on my machine, but received the error message in the following image here.

I uninstalled and re-installed it and it appears to be showing the same error message. I downloaded the Rekord Buddy Beta MSI file windows file you posted in the forums here. Is this the correct version?

Please note my specs below:

Any update on this?

The same issue is happening, and I’m getting the same error message (see attached). I also purchased the license for $49.00 today. I would have waited if I had known there were issues with opening the software. As of this moment, the application does not run at all. You are not able to bypass this screen to continue with the software. I’ve also tried it on two other Windows 10 machines as well, and I get the same result.

Could someone please let me know if I’m missing something here?

Please help!


hello everyone. Just wondering if this has been resolved? Im planning on downloading the windows beta to replicate my serato cue points and loops across to Rekordbox.

nope. still broken.

I’m looking at it now. No other releases has been made since the first beta on Thursday so nothing would get fixed on its own :slight_smile:

This is caused by some Qt stuff that apparently the app finds on my computer but not on regular installs. I need to ship the app with them it seems.

That’s what betas are for :heart_eyes:

1 Like

This should be fixed in 2.2b2. You can use the same link in the 2.2beta thread to download it.

1 Like

Well Done @damien this issue seems to be resolved for me! :wink:

1 Like

That was quick! DLing now. Thank you

1 Like

If the app launches for you guys now, let’s start using it and see where the next brick wall is :joy:

I’m on deck to fix anything that comes up.

I think you are officially the second person on the planet to run Rekord Buddy on Windows :slight_smile:

This QT platofrm error is resolved for me. Another startup error is now appearing instead, but that is already described in another topic.

This appears for me when trying to launch. Anyone know how to address this?! Have tried reinstalling already, no difference

@aotis let me look at this one, it’s not something you can fix on your end.

@aotis you have to install the last Visual C++.
You can download it from Here . Choose the one which is correct for your machine (x86 or x64), probably you run a 64bit Win OS so you would need the x64 one.

After the installation of the Visual C++ Rekord Buddy will be able to start as long as this is the only issue for you.

@rosgr100 @aotis I don’t recommend doing that. This is a missing dependency on my end which should be dealt with by the app installer, not by installing some other app. I’m working on beta3 now.

1 Like