Shifted beat grid and/or loop when importing from Serato to RB

My Rekord Buddy Version:
2.0.22 (217)

My OS Version:
MacOS Mojave

Steps required to reproduce the problem:

  1. Import track (mp3) in Serato
  2. Create a Cue point and then a saved loop from that key point
  3. Sync with RB

What I expected to happen:
The beat grid and/or loop should be in the same spot like in Serato.

What actually happens instead:
Either the beatgrid or Memory loop (can happen with both but not at the same time) is shifted. The shift is usually a bit to the right. If the beat grid is good then the loop may start a bit shifted. If the beat grid is shifted, usually the Memory loop starts at the grid marker.

Both beat grid & loop are off:

Serato:

This is how it would look like if the beat grid would have been correct (some cases):

LATER EDIT
It seems that is caused by some kind of incompatibility. If I do the reverse (RB => Serato) with the same track I get the following result:

Are these MP3 files? There’s a known issue with how rekordbox handles beatgrids that causes them to be off when imported into Rekord Buddy. I’d suggest using the stable 2.1 beta, as there were a few fixes to compensate added to the code.

Yes. It’s an MP3. I tried to use the latest beta but I don’t have a sync button anywhere so I reverted to the non-beta version.

Did you try the beta I linked to? the newest beta is bleeding edge and not for stable use. The one in my previous post is stable and has a sync button.

No. Missed the link. Will try today and I will let you know.

So I have tested this with track that was not aligned properly (can’t remember what track I used in my initial post) and it seems to work fine. I will update the post if something else comes up.

That’s good news. Keep me posted.

This topic was automatically closed 333 days after the last reply. New replies are no longer allowed.