Release years not updating in Rekordbox


macOS Sierra Version 10.12.5

I have been updating songs in my Serato with more accurate grids, hot cues and release years for each song.

Unfortunately I can’t get the release years to update after I export the songs back into Rekordbox.

Any songs that I export from Serato to Rekordbox, for the first time have the correct release years that I typed in.

Unfortunately any songs that I had previously exported into Rekordbox without release years, show a 0 in the year column, despite the fact that I’ve updated them in Serato before exporting.

I have tried deleting the Rekordbox.xml file to see if that would allow me to reset my rekordbox library, but this stops Rekord Buddy from being able to export to Rekordbox.

The above image is a playlist in Rekordbox. In Serato, every song in this playlist has a release year tied to it

I’m moving this to the beta category.

There is no Date Released field in the data that rekordbox currently imports but the year should be correct.

Can you hit me up via support and point to this thread so I can take a look at your Serato collection? Maybe you’ve found a specific issue and can qualify for a bug bounty.

I’ll post back in this thread once we’ve figured out what’s wrong.

Hi Damien. I tried a few things out myself… So far the only solution I’ve found is to completely uninstall rekordbox. Make a fresh install, and then export everything from Serato back to rekordbox again. I’m running Serato 1.9.6 and rekordbox 4.5 if that helps at all.

I don’t have my laptop to hand at the moment but I’ll follow up with you when I do.

Re-installing sounds like hocus pocus, if anything it’s hiding the problem instead of fixing it.

Did you contact me via support so I can take a look at your Serato collection?

Yeah, it’s not ideal, but it works as temporary fix.

I’ll contact you once I get back to my MacBook at home, as that’s where my main Serato and Rekordbox collection is stored.

Just updating the thread. There is a support ticket opened now and I’m looking into it.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.