Rekord Buddy Will Not Download

I just purchased this software, and was very excited to give it a go, especially when faced with the prospect of re-doing cue points and loops on an entire library. After my purchase was completed, I clicked the link but none of the links work to download the app. I am very disappointed and need someone to tell me something.

You can access both the license key and latest installer by logging into the site and going to your purchase history.

That is where I accessed it from. I clicked the link in the email that I was sent, as well as from the MyAccount tab after logging in to the website. The attached picture is the direct result of that.

I just purchased Rekord Buddy and I am experiencing the same problem. The link to “Rekord Buddy 2 Installer” took me to a warning by chrome that someone was trying to intercept my connection - something about the security certificate. I proceeded anyway, and ended up at the 404 page shown above.

1 Like

I purchased and the same thing is happening to me. I get the 404 page. Does anyone know a solution?

This was a certificate issue that should be resolved. Let me know if it hasn’t

I just tried a moment ago, and still got the same thing.

Has anybody gotten this to work yet?

Still getting the 404 page as well, with a strikethrough through the https in the URL. But at least the 404 page is loading faster this time :slight_smile:

Can we get an update?

Hello? Can anybody answer? Are there any updates?

Hi all. Yep, we’ve realised it’s still not working. Will let you guys know when there’s news, and if we need to provide an alternative way to access.

EDIT: and sorry about this, of course!

The issue was a certificate that expired (with the auto-renewal failing of course) and that was fixed yesterday. It’s working correctly for me right now so the next step is to figure out what is cached on you guys’ end and causing you to still see the problem.

Can you try clearing your caches and if you do have another browser available try another browser to go to (or maybe from your phone) to make sure that that works.

We can take it step by step from there.

Well… it after 3 attempts your hosting company doesn’t succeed then try a fourth time. Geezzz… I think they’ve fixed it now.

Sorry about that guys, I wish I had the time to cut the middle man and host the site myself but unfortunately I have to rely on people who apparently can’t do their jobs to save their lives.


Thanks. I think I got it now…

1 Like