Rekord Buddy 2 quits unexpectedly

MacOS Sierra 10.12.16

Latest Rekord Buddy

Application will not load up and if it does it crashes right away. Help please

1 Like

Do you know which version of Rekord Buddy you are using? Did you try downloading the latest build by going to your account (in previous purchases).

I just purchased rekord buddy last night and I downloaded the latest build.
Any ideas?
Thank you in advance

It’s probably 2.0.20 then. Let me see if I can find your error report.

1 Like

Same here. Just updated to the latest version. Since then Record Buddy crashes while app start and is not usable anymore.

Mac OS 10.12.6

has to be a bug… please help lol
thank you for the quick reply

this version. i had to record from screnflow and take a screenshot since the app is unusable

Upgraded today … had the latest version … got the notification there was an upgrade. Now it crashes on opening every time.

Unfortunately none of you guys are sending a report to me with something identifying you when the app crashes. This is most likely because the crash happens so early that the identifier hasn’t been setup yet.

I have some issues that are logged that are probably amongst the ones you are seeing. I will keep working on figuring those out and report what I find back here.

1 Like

Hi, is there any way we can get a hold of an old working version?
My Rekord Buddy was working fine until I updated 2 days ago, and now it can’t even start the app. I’ve tried downloading the latest version from my account, also the latest beta, and in both cases I get the same result, crash before opening the app.
I usually use Rekordbox but this weekend I NEED to use Serato and now I have no way to do so. PLEASE HELP! :slightly_frowning_face:

1 Like

any update on this? thank you sir

I’m fixing launch issues with every new build (I also unfortunately created a new one in a recent build but that’s the risks of trying to be fast by posting live releases).

Since I can’t identify your issues separately (the problem happens in the app before I have time to add info the the issue reporter), can you guys keep posting here the last version number you tried so that I know who still has problems?

I’ve been posting builds every day and we’re up to 2.1.16 right now. You can find new builds in the Previous Purchases section of your account.

Let me know if this is still happening and make sure you download the latest build, then let me know if what you are seeing is a crash or a ‘Something wonderful’ dialog.

This topic was automatically closed 333 days after the last reply. New replies are no longer allowed.