Rekord Buddy 2 crashing at the end of import/export

My Rekord Buddy Version:

My OS Version:


Steps required to reproduce the problem:

  1. import from traktor
  2. or export to rekordbox

What I expected to happen:

a successful import or export

What actually happens instead:

app crashes (see image)


I am having the exact same problem.

Welcome to the forums.

I am just about to ship 2.1 so it’s unlikely I’ll get a chance to look at this before that happens. Do you want to try the latest beta and see if you still see the issue? If you do, that would be a high priority for me to fix.


Great, in that case I’ll wait for 2.1 as I’ve tried the beta already and it didn’t look workable…

Thank you.

Sounds good.

I don’t know how long ago you’ve tried it but it’s pretty stable right now.

Hi Damien,

Here’s the error message I’m getting now I’ve installed the Beta.

Nate 22

That looks like you don’t have a useable internet connection. Does your computer use a proxy or an internet filter of any kind?

Not that I’m aware of. I’ve updated to 2.1 now, but still having the same problem. Please see image, thanks. 32

Thank you! you’ve triggered a new error that I added to try and diagnose the problem.

When you first launched the app, did it ask you to enter your license key again?

If yes, how many characters is the license you typed in then?

Great. It didn’t ask me to enter my license key, despite re-installing the software and de-activating my two licenses.

Thank you for all your hard work by the way.


I really appreciate this @Nate, thank you.

I just posted 2.1.4 which should fix the issue with the licensing error.

I just upgraded to the new 2.1.4(664) and whenever I try to drag a playlist from Serato into Rekordbox the program crashes and I get this error


I haven’t transferred my whole Serato collection yet to Rekordbuddy due to time constraints at the moment, so I’m trying only playlists or single tracks but I keep getting the error.

@asey Can you try 2.1.5? I just posted a fix for something that could be your issue.

Just updated to 2.1.5, same issue and error message :’(

You currently have 3 different issues it seems. I just posted 2.1.6 which fixes one of them related to invalid years in Serato tracks and gets me more info on the other two issue.

Keep on getting me the reports (“Something wonderful” dialogs) and I’ll keep on fixing the issues.

It’s a bank holiday in France today but I’m on deck, fixing stuff.

2 posts were merged into an existing topic: No cue in rekordbox from Serato

This topic was automatically closed 333 days after the last reply. New replies are no longer allowed.