Problem with Rekord Buddy sync to Recordbox

Hey, unfortunately I have a huge problem with my Rekord Buddy sync my files from Traktor to Recordbox. I will try my best to explain my problems.

I use a MAC with OS 10.15.3
Rekord Buddy v 2.1.4(662)
Traktor 3.3
Recordbox 5.8.5

My workflow so far was that I import my new tracks in to iTunes or (Music as it is called now). From there I used the bridge to my Traktor and imported the last added songs to a my playlists where i analyse the songs, set cue points, beatgrinds etc.

Then I used to open the Rekord Buddy app and transfer my playlists to rekordbox, everythink worked fine. But since the last time i have a big problem. First when I open Rekord Buddy the Rekordbox Tree looks very different then he others. There are a lot of duplicates. When I delete the duplicates, they are back the next time i open Rekord Buddy, and i Rekordbox i never see a change.

Second and the much the bigger Problem is:

All my playlists contain the correct songs in Rekord buddy for Traktor and Rekordbox but then i open Recordbox and go the the rekordbox xml playlist and all my songs are replaced by a song which isn’t even in the playlist and worst I don’t like the song either :sweat_smile: :hear_no_evil:

And i have that problem in nearly every playlist now which isn’t that great.But for my newest 2020 playlists, it worked fine and correct again, today.

Of course i could use Traktor but for gigs i like to take my recordbox files on usb stick and play with them. I hope you can help me. I tried already to deinstall and install again, to delete everything, started from scratch but i have always the same problem.

Looking forward to hear your solutions best regards and thank you

Ok first thing to do is to update your copy of Record Buddy. As of today the latest build is 2.1.38 and a lof of things got fixed since 2.1.4.

Try that, open the rekordbox collection in Rekord Buddy and see if it tells you anything about finding some corrupted entries. If so, save the changes on exiting and let’s take it from there.

@damien Stupid question, but shouldn’t be v. 2.1.4. newer than the v. 2.1.38?


@damien ok i was wrong^^ i did the update and reinstalled recordbox, now everything is working fine again thank you very much :+1:

You’re welcome. Glad I could help.

This topic was automatically closed 333 days after the last reply. New replies are no longer allowed.