No cue in rekordbox from Serato

**My Rekord Buddy Version: 2.1.13(671)

**My OS Version: 10.13.6

I try to export from serato dj pro to rekordbox. Works perfect, except the important thing - cue points. When I check in Rekord Buddy, I can see all cue points but nothing in rekordbox. I drag and drop from Serato to Rekordbox in Rekord Buddy. I’m doing anything wrong?


I’ve finally been able to export playlists/tracks from Serato to Rekordbox without crashing, but my newer cue points are still not transferring : (
I just updated to V. 2.1.13(671)

Describe the steps you are taking when updating new cue points.

In rekordbox do you import the track again from the rekordbox XML?

Can you try deleting a track in rekordbox before re-importing it? There is a bug right now that makes this necessary for some changes to appear.

I moved some messages from another thread to here since this looks to be the same issue. Please see my questions above.

I have delete tracks in rekordbox. Trying to import different tracks, thats never been imported before - but still no cuepoints… i’ll try to delete rekordbox.xml and try again.

I did this…

macOS 10.13.6
Rekordbox 5.7.0
Rekord Buddy 2.1.17 (675)

I deleted rekordbox.xml - created a new one.
Copied a new playlist from serato to rekordbox.xml in rekordbuddy
Open Rekordbox
Go to Rekordbox.xml - right click and import playlist
Go to Video Playlists - All tracks
Drag one track to the player - no cue points.

When I jump back to rekordbuddy and show information about a mp4, then i see that rekord buddy found cue points.

Is this where the serato cuepoints are, but it forgot to copy that information to where rekordbox reads the cue/memory information?

Damn… I have tried tons of thing, but can’t get it to work. I must do something wrong - but I can’t figure out what it can be.

Let’s take it step by step:

  • Pick one track in your Serato collection.
  • In Rekord Buddy, in the Serato section, right click on that track and looks are the marker info tab. Do you see cue points?
  • Drag that track from Serato to rekordbox.
  • In Rekord Buddy, in the rekordbox section, right click on that track and looks are the marker info tab. Do you see cue points?

Here have you two pictures - one from rekordbox in rekord buddy and one from serato in rekord buddy.

I try to move FROM Serato TO Rekordbox.

A picture is worth a thousand words :slight_smile:

Ok so it looks like you have some cue points in the Serato tracks and the same cue points (with memory cues) in the rekordbox track.

Drag that track from the Serato playlist onto the rekordbox, then look at the track edit Window in the rekordbox section again. The track should only have hot cues now and the message saying it’s not compatible with Serato should be gone. Correct?

Sorry, I think i forgot to explain it.

I have already moved the playlist from Serato to Rekordbox. (first picture is after i drag the playlist from Serato to rekordbox (in Rekord Buddy). Second picture, thats the track info from the serato playlist.

Don’t really get what I should do?

When I add the files/playlist in rekordbox (get the files/playlist from rekordbox.xml), it’ll show 0 cue points and so. Nothing there, but in rekord buddy you can see it’s hot cues/memory cues.

So Rekord Buddy shows you that the XML file it’s updating does contain the hot cues (and also the hot cues duplicated as memory cues which is probably the way you have it set up in the preferences).

So now we need to find out if your rekordbox xml bridge is set up correctly so make sure rekordbox is looking at the same file that Rekord Buddy is writing to. In the rekordbox preferences, in the rekordbox xml section, select the current path to the XML file and delete it. Pressing enter will reset this to the default path which is what it should be.

Now, there is a bug in recent version of rekordbox that prevent things from getting updated when dragging tracks over existing ones so let’s do this as a test: Delete the track from the rekordbox collection and then drag it from the XML bridge in the rekordbox collection.

Do you see the cue points on that track then?

I have done what you told me to do, i hope :slight_smile: But nothing :frowning: I have deleted, re-add, deleted, re-add etc etc… but nothing… Fuck rekordbox :stuck_out_tongue:

It may not be rekordbox’s fault, hold on… :stuck_out_tongue_winking_eye:

It seems pretty certain that the XML contains the right info since Rekord Buddy is able to display it. I still think that somehow your rekordbox is not looking at the right file. Can you post a picture of the xml bridge setting in rekordbox so we can see the path it’s using?

Okie, here is the path. It’s the right because rekordbox only show the playlist that i have added in Rekord Buddy.

The plot thickens. The path is correct. Do you know how to check if the track contains the cue points in the XML or do you want to send me that file so I can check myself? (you can DM me a link).

So… the XML file you send me does not have the track you are looking at (Mall Santa) or the Playlist in your screenshots. Did you make changes to the rekordbox collection after you make the screenshots above?

That’s true - because I have delete and re-add tracks… But I can add these tracks that you have in the xml to RekordBox / RekordBuddy and send you some new screen shots…

When, not IF, when you solve this issue… I’ll definitely subscribe to this software… It’s magic if it works, and it’s much much faster then the 2.1 beta i got working last time. :slight_smile:

1 Like

If you don’t mind, let’s use the latest build (should be 2.1.21 I think right now) and copy some tracks or playlist over to rekordbox. Then save the changes and check in rekorbdox to see if the cue points come thru.

If they don’t, DM me the updated xml file and I’ll take a look.