Issue launching v2.1.40 on Mac Catalina

Hi there,

I had the v.2.1.36. I tried to import from my Serato playlist a large bunch of track (40k) as I updated my track infos .
When I opened the software and drag to rekordbox playlist or Rekord Buddy playlist it crashed.

I tried several time with same issues until the point I could not launch it anymore.

I looked this forum and have seen there was an update (v.2.1.40) so I downloaded it.

I still have an issue, I even can’t launch the software, it still stuck to the launch page at “Readying the FLAC jacket”

Any advice?


Looking at your reports I see two things. The current issue seems to be a database corruption so let’s try and reset your database and see if the app launches again. That’s step one.

Step two is to find out what cause the corruption. I see a lot of your reports look like you’re running out of memory when doing a copy. In order for us to learn more about the cause, can you make sure that smaller copies (not 40k things at one time) work without causing any issues?

This helps us with two things. One, to make sure that the issue is only memory related in which case I can try and see what is using so much memory, or if the issue happens again with smaller copies, to give us a smaller dataset in which to investigate the problem.

Thanks for your replay.

I will reset my database and try small importation.
Thanks :slight_smile:

And make sure you try with a smaller playlist and let me know if that works. We can track down the issue step by step that way.

It’s working now thanks

1 Like

If it happens again, try to identify which step created the problem so that we can try and replicate it to fix the issue.