Hot Cues on Serato not Transferring to Rekorbox


Apologies in advance for the new thread on an existing topic, it seems like the other people having trouble with this have some unique situations (transferring video files, some hot cues vs. all hot cues, cues showing up in one library and not both in Rekordbuddy, etc.) and I haven’t found a solution that worked for me in those threads, so I created a new one.

macOS Catalina 10.15.2
Rekordbuddy 2.1.36
Serato 2.3.2
Rekordbox 5.8.2

Issue: I have a very large music collection (about 10k songs) on Serato, almost all of which are MP3’s, and a majority of which contain hot cues. As such, I downloaded Rekord Buddy 2 for the sole purpose of transferring the tracks WITH their cues. On Rekord Buddy, when I transfer the tracks from Serato to Rekorbox, it shows that the cues have been converted to memory cues in the “marker info” of the track details.
Serato library (origin):

Rekordbox Library (destination):

After quitting (and saving!), I open Rekordbox, make sure to load the correct xml, and import the tracks that have newly appeared after being transferred, however none of them have cue points. If I try to load a track before importing, it also does not show the cue points. If I do it one song at a time, it’s hit or miss, sometimes the cue points will show up, sometimes they don’t, and I can’t predict the behavior. Sometimes, the same song will even show cue points after a few repeated attempts. If I do something like 100 or so songs, a small handful might have the cue points appear, but it’s also hit or miss. Besides that though, I shouldn’t have to do it one by one or in small batches. The whole point of purchasing this service for me was to not do it one-by-one, especially because of the size of my library, but since the moment of purchasing the product, I’ve only been wasting time trying to get the damn thing to work.

Some quick notes to anticipate solutions that haven’t worked for me:

  • In Rekordbox’s preferences “rekordbox xml” under “view” -> “layout” -> “tree view” is checked
  • In Rekordbox’s preferences under “advanced” -> “database” -> “rekordbox xml”, “BPM change points” is checked and the imported library is the same one I exported originally from Rekordbox and use in Rekord Buddy.
  • The transferred tracks do show up in Rekordbox with their beatgrids, but do not have any saved cues there both before and after importing.
  • In Rekord Buddy’s preferences, under “Rekordbox”, “Duplicate hotcues as memory cues when writing to rekordbox” is checked and under “Serato” “Convert memory cues to hotcues when writing to Serato” is checked.
  • I’ve confirmed that the tracks I’m transferring have cue points on Serato, and that the cue points show up in Rekordbuddy under “marker info”.
  • When I transfer the tracks on Rekord Buddy from Serato to Rekordbox, the track in Rekordbox has twice as many cues (as shown in the above picture), so I assume the Serato hot cues are being successfully converted into Rekordbox memory cues.

Praying there’s an easy solution that I overlooked, but it’s not clear in the user manual or online resources. Please advise.

First of all, welcome to the forums and thank you for the super thorough report. You are my hero.

First quick test, let’s pick the track that you are looking at: “Zoom” by Spag Heddy. Can you delete this track in your rekordbox collection (from the collection, not just from a playlist) and then re-import it from the rekordbox XML bridge. Does that bring the cue points in correctly?

Thanks Damien!

So yes, I went ahead and deleted it from my Rekordbox library and re-imported it from the XML bridge and the cue points did show up for this track.

This isn’t the case across the board though. For example, here’s another song in my Serato library which I transferred to Rekordbox yesterday and had the cues show up in Rekordbuddy but not in Rekordbox. I just tried deleting it from my Rekordbox library and re-importing it from the XML and they still don’t show up. So even if I only do one song at a time, it doesn’t necessarily work.

Note that the reason there are multiple Rekordbox and Serato libraries in Rekordbuddy is because all my tracks are on a USB. The xml file is saved to the USB and is the one titled with “user location” and my origin tracks only appear in the Serato library with “on NO NAME” in the title; these are the two libraries I use while using Rekordbox. If I try the process with an xml saved to my desktop, I get an error something to the effect of “tracks are on different volumes” which gives me the same result, but additionally creates a problem where I have to press “ok” for that error for every single track I try to import, which both doesn’t solve the issue and then is further impractical because of the amount of songs I have. If I accidentally click “cancel” on any of the error dialog boxes, all the songs fail to transfer.

Ok let’s take one issue at a time.

  • The ‘deleting the track in the collection for changes to be imported’ is a rekordbox bug. It sucks and I’m working with Pioneer on getting this fixed. In the meantime, that’s the fix.
  • The ‘tracks on different volumes’ is a bug fixed in the current bugfix release. I’ll DM you a link to that so that you can try it out.
  • I don’t know why you would need a separate rekordbox XML in your case. This may be part of the problem if rekordbox is looking at the default XML file but you are modifying the one in your ‘user location’ instead. I recommend removing the ‘user location’ collection in Rekord Buddy and only updating the main rekordbox XML file. You can then make sure that rekordbox points to the default file itself before trying again.

So I’m getting a couple new issues with the build you sent me.

First, after transferring tracks from Serato to Rekordbox in Rekord Buddy (after creating an xml on my desktop from Rekord Box and dragging it over and confirming that i want to replace the library with that xml), the tracks look like they’ve successfully transferred in Rekord Buddy (they appear in the Rekordbox library in Rekord Buddy), however when I exit and click “save”, then open Rekordbox, go to preferences, navigate to the xml on my desktop, and refresh the xml library within Rekordbox, none of the tracks appear at all (oddly enough, the very first time I tried, about 2k/9.5k appeared, but again, mostly had no cues, however everytime I’ve tried since then yielded no tracks at all appearing). When I close Rekordbox and re-open Rekord Buddy and go back to the Rekord Box library there, I get this message.

From here, if I close Rekord Buddy, save again, and go back to Rekordbox, the tracks still don’t appear at all, but I only get this message the first time I re-open Rekord Buddy, so if I re-open it again and go to the Rekordbox library in Rekord Buddy, the message doesn’t appear again.

When I do go back to the Rekordbox library within Rekord Buddy, it shows that all the tracks are there, however, if I try to re-drag the same xml file which I originally dragged onto it, the tracks all disappear. I deleted all the tracks in my Rekordbox library in the very beginning, so this makes sense as the starting point, but not as the ending point, so I’m guessing this means that the xml file isn’t successfully getting updated after closing Rekord Buddy in the new build.

I also tried the process again, but tried saving the xml to the USB, and had the same exact results. In this build however, I couldn’t drag the one in the USB underneath the other libraries in Rekord Buddy to create that “user location” library, doing so just didn’t do anything at all, so in the USB XML trial, I dragged it over the Rekordbox collection just as if it was an xml file on my desktop.

This issue occured when I tried transferring 1) my entire library 2) 20 tracks and 3) one track

Here again, let’s do one thing at a time because it helps identifying issues one by one.

Do you still have a ‘user location’ rekordbox collection in your Rekord Buddy window? If so right click and remove it. You shouldn’t need this.

Let’s make sure that rekordbox is looking at the right file. In the rekordbox section in Rekord Buddy create one playlist as a test. Let’s name it ‘My Test’. Drag one track in it. Exit and save.

In rekordbox, in the rekorbox XML section, do you see that playlist?

This topic was automatically closed 333 days after the last reply. New replies are no longer allowed.