Failed to create OpenGL context on launch

I dont get the runtime error anymore but now i get this with the latest beta from last night:

Failed to create OpenGL context for format QSurfaceFormat(version 2.0, options QFlagsQSurfaceFormat::FormatOption(), depthBufferSize 24, redBufferSize -1, greenBufferSize -1, blueBufferSize -1, alphaBufferSize -1, stencilBufferSize 8, samples 0, swapBehavior QSurfaceFormat::DefaultSwapBehavior, swapInterval 1, colorSpace QSurfaceFormat::DefaultColorSpace, profile QSurfaceFormat::NoProfile) .
This is most likely caused by not having the necessary graphics drivers installed.

Install a driver providing OpenGL 2.0 or higher, or, if this is not possible, make sure the ANGLE Open GL ES 2.0 emulation libraries (libEGL.dll, libGLESv2.dll and d3dcompiler_*.dll) are available in the application executable’s directory or in a location listed in PATH.

my laptop has switchable graphics…and I tried other software that uses OpenGL. They do work. So it seems that maybe RekordBuddy is not making whatever call to the OS that it requires openGL and then craps out

I also tried setting RekordBuddy in the GPU driver utility to use the openGL card. still errors

This is most likely a requirement by Qt which is the windowing system Rekord Buddy uses. I don’t develop Qt myself and unless this is something that hits a lot of people, I don’t think this will be a high priority to fix on my end.

I’l separate out this issue into its own thread, that way people can comment if they are getting the same problem.

You can test this by:
Disable your gpu in device manager. Launch Rekordbuddy.
Enable gpu and disable intel integrated graphics. Launch Rekordbuddy.

If Rekordbuddy is able to launch in both scenarios, but not when both are enabled, it’s an opengl issue. If Rekordbuddy launched in either one of the scenarios, then it is a graphics driver issue.

What is you current cpu, graphics card, and laptop model number?

1 Like

GPU = radeon 6700m and Intel HD Graphics 3000

Core i-7 2760Qm

This is the laptop below. One issue is that it doesn’t “support” windows 10, but everything is working except launching Record Buddy, which has never worked