Exporting to traktor seems to do nothing

My Rekord Buddy Version:
My OS Version:
Steps required to reproduce the problem:

  1. Import from RK --> everything was imported successfully.
  2. Export to Traktor (3.1.1) --> Very fast, successful message.
  3. Opening Traktor --> nothing was changed.

What I expected to happen:
Traktor library should be the same as in RK
What actually happens instead:
Nothing was changed in Traktor

Tried after updating to Traktor Pro 3.2 and I have the same result.

Tested with Beta version 2.1 (build 630, somehow can’t download 639). On both the released version and the beta version, the .nml file is being updated.


same result with export to Serato or Rekordbox.

@oggioo Are you saying the file is being updated but no changes in the tracks are being added to it? My first thought was that you’re not pointing/looking at the right Traktor folder on your machine but I could be wrong.

@Myles I think you’re referring to a different issue than this one.. If possible, try to keep similar issues in an existing thread to make it easier to keep track of.

@Damien, the Traktor is being identified (installed on the default location). I thought like you, and I chose the location of the. nml file on the settings. But still, the same results.

The file is not being updated at all (timestamp isn’t being updated)

Hi, the same problem. after export to Traktor - nothing to change.

  1. import first to RB2 from Traktor
  2. make smart playlists
  3. export to Traktor
  4. nothing to change in Traktor

Ok, let me put together a new build with some debug information that you guys can try.

Can you all confirm that the path to the NML file listed in the Record Buddy preferences is the one to your correct (latest) version of Traktor?

Can you guys try updating to 2.0.25(564)? I think that fixes the problem.

Sorry, from where can I download this build?

Check for updates in the app or use the download link in your purchases on this website.

Fixed. Playlists are successfully exported to Traktor.

1 Like

This works. Back in business! Thanks!

A post was split to a new topic: 2.0.25: Crash when importing and exporting

This topic was automatically closed 333 days after the last reply. New replies are no longer allowed.