Does it work with Serato DJ Pro 2.x & Rekordbox 5.6.x?

I am looking to switch from SDJ to RB, but, currently I have Serato DJ Pro 2.0.5 and RB 5.6.0 installed and the system requirements mentioned for Rekordbox Buddy 2 have a lower version than what I mentioned above.

Does it work with the versions of software that I have?

Welcome to the forums!

haven’t updated the requirements in a while so that’s my fault. I try to support all the latest release version and typically will post here if a new release is incompatible with the current Rekord Buddy.

So in your case it should work fine.

This topic was automatically closed 333 days after the last reply. New replies are no longer allowed.