Can't authorize Rekord Buddy 2.0

  • I am using Rekord Buddy 2.0.29 and macOSX 10.10.5

  • Why you are unable to upgrade to the latest 2.1 version

When I checked for updates (last time the program worked it said I was on newest version). Where can I find 2.1 and is it compatible with my OSX?

It is odd though that it was working fine until a week ago.

Thanks for the help!

2 Likes

Greetings,
I just started to get the ‘Can’t authorize Rekord Buddy 2’ prompt. It’s the 2.10 beta (557), on OS X Yosemite 10.10.5

I can’t install the latest version because it says it requires OS X 10.12 or later. I’m using a 2009 Macbook Pro that is only for DJing. It’s too old to update OS X, and I’m not sure if this MBP supports any later version of OS X.

I wasn’t aware of a new version of Rekord Buddy as the “beta” was checking for updates automatically. I was getting curious why it was still in Beta, but I haven’t checked in here for quite some time.

Perhaps some users would prefer a scaled-down version of the program that operates like version 1. A 1 button interface with “import from” and “export to” drop down boxes, and preferences for copying grids, tags, cue points and copying hot cues as memory cues, etc. I believe some of us don’t need to edit tags within Rekordbuddy since we do that in our main DJ software.

3 Likes

???Just checking???

Guys somebody help me here I really need to use RB and cant

ANYBODY???

1 Like

Thread keeps getting bigger… any one have any luck yet?
Bunch of us are still unable to use Rekord Buddy.

Hey guys,

Thank you for all the info on your separate situations. I’ve just spent 4 days getting a dev machine back up and running in order to be able to compile the 2.0 codebase, then implement a fix to the auth issue, then test the fix with he new auth server. All these things take longer these days because I also have to spend some time home-schooling my kid so I don’t have all the time I normally have during the day.

Ok so, before I give you the link to the new build, let’s post some things one more time to clarify what the situation is:

  • 2.0 is no longer supported. As I painfully realized doing this fix, old builds take a huge amount of effort to maintain and I don’t have enough bandwidth for this. But since the issue came from something I did to upgrade the servers, I decided to do the right thing and provide you guys with a fix anyway.
  • The fix comes in the form of build 2.0.30 which will keep the same functionality as the last 2.0 build ever released (2.0.29) but it will only work on macOS 10.10 and 10.11.
  • If you are running macOS 10.12 or above, you are expected to upgrade to the latest supported build of Rekord Buddy. You can find more info about downloading the latest build of Rekord Buddy in this entry in the manual.
  • If you are stuck on macOS 10.10 or 10.11 because of some other software or hardware issues, then this fix is for you and will keep you going. This remains unsupported and I can’t guarantee that I’ll be able to provide any more updates after this one.
  • Build 2.0.30 now contains the same analytics as the 2.1 build. This will send me anonymized data on your OS version and the version of Rekord Buddy that you use in order for me to see how many percent of my users are 2.0 users. The bigger this number, the more likely I am to continue to help you guys out if you have no other choice. This is why this build is only for 10.10 and 10.11 users. Others should upgrade to 2.1.

Now I’m not going to start another discussion on who likes 2.0.22, who likes 2.0.29 and who doesn’t like drag and drop. The goal is to provide all the functionality that you guys need under the new 2.1+ codebase. If you are able to use 2.1 but would prefer if the functionality was different, let’s start a separate topic and I can explain in a little bit more details where things are heading this year.

Just to be crystal clear, the solution will NOT be for me to re-issue a 2.0.22 build. It was buggy, caused issues and was making my life hard maintaining it. Everyone will do better if the most people possible upgrade to 2.1 and we work to make that work for the majority of people.

So, with you further ado, here is the new build. If you are running 10.10 or 10.11, try it out and let me know if it works for you.

If anyone is having issues with the new build, let me know what OS version you are using so I can try and repro. My dev machine was running 10.12 so I’d have to make a new one with an older OS maybe.

I’m running 2.0.29 using Mojave what should I do? Can you give me a link to the build which will run using Mojave or an alternative? if I have to upgrade to 2.1 thats fine. Where is the link for this plz

R

1 Like

Hi Damien, I’m really sorry to bother you again. I’ve tried to install the latest version of RB to solve the problem, but it keeps saying I have no activations left. I’m very sure I’ve only used - or try to use - RB on 2 MacBooks. What could be wrong? I’ve tried to get RB working again for many days now, so it gets on my nerves…

Upon trying to launch this new 2.0.30 build I get the Following mesage "couldnt generate a random user ID… app will exit.
Screen Shot 2020-04-20 at 1.30.39 PM

I am running OSX 10.10,
and btw Thank you
Much appreciate the attention and trying to get this up and running.

Hi Damien,

On the purchases page in my A/C in Next Audio there is only the RB2 installer. I can’t seem to see where there is any info about an update. Or is it within the installer? As i am running OS 10.14.5 Mojave and currently using RB 2.0.22

ps- It’s not in the installer as the installer is for RB 2.0 only.

Again, any link or info on upgrading RB for those of us that run Mac. OS higher than 10.11? As it isn’t showing in my past purchases.

Thanks again,
Athol.

Check out my reply above :slight_smile:

If you are running macOS 10.12 or above, you are expected to upgrade to the latest supported build of Rekord Buddy. This can be found in your Past Purchases on the main next.audio website.
So log in to the main next.audio site, look in Past purchases and you’ll find a link to the latest build. It is an installer, you just drag the app over the old one via the DMG file.

Let me know what you are seeing if that doesn’t work. The main installer (dmg file) is the current 2.1 build. Can you make sure you downloaded, installed and are clicking on the right one?

You’re very welcome. I broke it so it’s fair that I fix it the best I can.

Let me try and put together a 10.10 machine to try and replicate the issue. It seems like it can’t generate a unique anonymous user ID for your machine but I’m not quite sure why that would happen. Stay tuned.

Hi Damen,

TY for doing your best to try to remedy this issue for those of us with older MBP’s.

I’m having the same issue w/ installing as vicangelo. Same error message.

I’m running OSX Yosemite 10.10.5

Thanks!

It’s there now. May have just taken a few hours to upload. But it’s now up and running. Thanks again for all of your help. Especially as you are also being Dad in between. Many thanks.

Thank you for understanding guys.

I am able to reproduce the issue on 10.10 with the unique ID generation. I’m looking into it right now.

Update: I’ve tried to de-authorize my licenses, to start all-over again, but when I try to manage my activations, this is not possible either. Please help!

Ok guys, if you are running 10.10 or 10.11 then try a new version of the build. Same link as before.

Long story short, that version of macOS is so old that it cannot connect securely to some servers anymore because the certificates have expired. I would really recommend trying to upgrade your OS if you can for security.

@beuzelen Don’t try random things, just read what I’m posting :slight_smile:

If you are using macOS 10.10 or 10.11 then try the build linked to in this thread. If you are using a version of macOS older than 10.11 then the explanation on where to find the latest build is right in this thread in my previous post:

I’ve now updated the manual with specific instructions for subscriptions versus one-time purchases so it should be easy to find the download link now.

Damien, I do read what you’re posting, but apart from English not being my mother-language ànd not being a wizard on computers, I don’t see the answer to my problem. As I told you I use Mojave, so I should download the latest version of RB. (If you are running macOS 10.12 or above, you are expected to upgrade to the latest supported build of Rekord Buddy. This can be found in your Past Purchases on the main next.audio website.) So I did. But I still get the message that I have no activation left. This can’t be the case, because, as I told you, I only use RB on two MacBooks and this should be possible. So please tell me what to do!

@beuzelen No worries. I think in this case I mis-understood what you were saying. I thought you were still getting the issue that this thread is discussing but you seem to be referring to an auth problem. I’ve manually reset your auths. Try now.

This latest build for OSX10.10 and 10.11 is Up and working perfectly.
Many Thanks!!!

1 Like