Can't authorize Rekord Buddy 2.0

hi. new reinstall. hasn’t worked in a while, giving it a shot again.

opening program while holding the ALT/OPTION key.

Saying “Can’t Authorize Rekord Buddy 2, Sever return error 8”.

Laptop has internet. (using it to write this). Running macOS High Sierra with the latest update as of today with Serato DJ Pro as of today. My profile says 0/2 activated.


I’ve moved your message into the support section of the forums.

I’m not close to a computer right now but my recollection if that this usually. means it can’t connect to our auth server. The server is up and running so it’s probably either confused or really can’t reach the server for some reason.

Let me confirm the error code and I will post back here.

Hi. Any word with this?

Sorry about the long delay. I’m wondering if your receipt file may be corrupted.

Could you try to rename your ‘Rekord Buddy 2’ folder inside your Music folder and launch the app. It will probably ask you for your license number again but then will perform a clean download of a new receipt.

Let me know if this makes a difference and we will take it from there.

Just to keep you in the loop, I’ve been selected for Jury duty so I only get to catch up with work on the evening right now. I do have your problem on my list and I will get to it asap. Thank you for you patience and sorry about that.

I recently Purchased Rekord Buddy 2 and I also have the same Problem , it wont load and wont authorize saying error 8 from server !! please help!

I reinstalled and still cant load it says : CANT AUTHORIZE REKORD BUDDY 2 : Server returned error 8, try again later or contact

Please help me fix this problem 59 USD is not cheap for something that does not LOAD!

Re-installing won’t change anything. It’s Windows apps that get ‘fixed’ by reinstalling.

As you can imagine this is not a widespread problem that I can reproduce myself otherwise it would be fixed already :slight_smile:

Did you try the suggestion I made in my previous post about renaming the Rekord Buddy 2 folder? This may help me get on the path of figuring out what is different on your setup than other people’s.


I just checked and there is no rekord buddy folder in my “music” folder in osx. Did a search in my folders within my profile and nothing came up with “rekord”

Please advise. Thanks!

Are you using version 2.0 or 2.1?

Looks like version 2.0.22

Ok, let me put together a custom build for you guys so we can get more information about the error. It’s definitely not normal.

Please update me on my email redacted if you come up with any solution or fixes , I still get error 8 message while trying to load

Hey @anoobisha it’s not a good idea to post your email in a public forum. I’ve redacted your post for security.

So both you guys’ licenses have never been activated, which means the app never reached the activation server for some reason.

Can you use the private messaging on this forum and send me you license KEY that you got for Rekord Buddy 2?


Instead send me a private message by clicking on my username and selecting ‘Message’. Thanks!

I have run into the same issue on Mojave (10.14 Beta) and 2.0.22.

Previously the app would crash at startup (I sent you all the reports that the mac generated) so I re-installed the app (and have tried the alt key) and now it says “Can’t Authorize Rekord Buddy 2, Sever return error 8”.

I must note I did have the app running fine in the past. My WiFi card got screwed and I’m using an external USB WiFi dongle - don’t know if its relevant but that’d be the only major change between working and not.

Any updates on this issue?

I had a couple of people with that issue, sent them debug builds to try and get more info but I never heard back.

If you’d be willing to try a debug build and give me some more info that would help a lot.

Sure send it over.

I got it to work for just under a day. It seems that when my computer runs out of juice/crashes/restarts kinda forcefully and the app isn’t fully closed shit hits the fan. Then the app can no longer be opened again as I mentioned above and just crashes instantly. Interestingly, upon reinstalling the app I get a different error (the authorisation error 8 as mentioned above, compared to just a crash of the app with no notice).

Basically this again:

(I guess it’s a good sign its more or less repeatable)

Will see if I can drill down the steps to reproduce. Send a debug version - I’m a bit of a programmer myself so I know what you’re going through :slight_smile:

That’s sounds awesome. Let me put it together for you.

Can you download and install this build:


  • Open the terminal app.

  • Launch the app from the command line by typing: /Applications/Rekord\ Buddy\ 2\\ Buddy\ 2\ Beta

  • If the authorization fails, send me the output of the terminal window. It might help me find where the problem occurs.

Hey! Sorry was gone for a while. I’ve switched since to the Beta version, which doesn’t have any authorisation issues. I’ve noted that once I try the beta I can’t switch back - is this the case? Can I still run some debugging tests for you with the older version?

Edit: By Beta I mean the Beta version available on the forums, not the one you sent over - not sure if they’re the same.