App quits after the splash screen

Hey Damien,

Just updated from 2.1.22 to 2.1.25(689) but app won’t open on my MacBook Pro. The splash screen shows up like if Rekord Buddy 2 is loading but then just disappears and no loading of the app. Tried resetting my database and license but end up with the same result. Also uninstalled and reinstalled but no go with the latest build.

Welcome to the forums. I moved your post to its own topic since it wasn’t;t related to the thread you were posting in. Check out this post for some tips on posting when asking for help.

Let me look at this, it could be related to a fix for another issue but the app seems to launch fine here.

I also have the same issue, just updated to 2.1.25 from 2.1.22 and the same thing happens. is there any way i can revert back to 2.1.22 as that worked perfectly?

Can you try 2.1.26 which should be available in the Previous Purchase section of your account? I think I may have found what caused this for some people. It’s could be side effect for a fix I did for other people. Let me know if it works.

Apologies, I will try it but I have no idea where the Previous Purchase section is on my account. been looking for it for ages.

I haven’t found the previous purchase page, i was able to download 2.1.26 via a link from one of my old Rekord Buddy installer files which suggested i downloaded 2.1.26 instead. I still have the same problem and it will not load after the splash screen.

Previous purchases is in the same section as your license key in the main website.

So just to make sure, you do see the 2.1.26 version number in the splash screen, correct?

I do, the splash screen says v2.1.26(690), I have just checked in my License Key section and there is no previous purchase option as it shows below in the picture.

You went too far. Click on go back and then in the previous page, click on View Details and Downloads for your purchase. There should be a section at the bottom named Products and underneath that a link for Rekord Buddy Installer.

My bad, I didn’t realise that’s what you meant by previous purchase. I’ve just done that, and downloaded again, i still get the splash screen and then nothing after that. I had v2.1.22 working perfectly yesterday

@Phil.22 Can you try 2.1.27?

Still no luck I’m afraid. Still getting the splash screen, now saying v2.1.27 and then it closes again. Very frustrating and thank you for your patience and effort in trying to fix it.

No worries. I want to get to the bottom of this.

Can you try 2.1.28?

It’s worked! its made it past the splash screen and now i can continue transferring music across.

many thanks for your effort and patience.

1 Like

No problem. Sorry for the inconvenience.

I will revisit this issue in the 2.2beta branch.

Thanks Damien…was able to open with 2.1.28(692) I’ve have moved over to Rekordbox but still love Serato Flip so I go back and forth with my gear and Rekord Buddy has made it super easy to share my library with each DJ software. Keep up the good work…us working DJ’s really appreciate it!

Now I did try Virtual DJ 2020 recently and most of my cue points were easily read without any 3rd party software right from my iTunes Library. Are they doing something similar to your software in the background? No configuring or exporting of my Rekordbox XML and was surprised to see everything working fine. Just curious what you have encountered.

@Genius211 There are no cue points stored in iTunes. They most likely are reading cue info from the track files themselves (in Serato format probably).

A post was split to a new topic: Hot to export to rekordbox

This topic was automatically closed 333 days after the last reply. New replies are no longer allowed.