2.2b14 windows app closing after opening

About 5 seconds after the app opens it is crashing, right not long after I click: OK, I understand I have backups, I get the app window up and then thats it. Help…

1 Like

Samesiew. The last beta was working fine. I’m thinking it was the addition of the daily note thingy. I’m hoping it’s something easy like that anyway. :-p

Same issue here.

By the way, Thank you for making Windows beta versions available, you are saving my life.


Just purchased and installed on 10 May 2020 and having the same issue. Will check back tomorrow to see if developer has a solution for crash.

Rekord Buddy opens. After licking the I Have Backups, I understand dialog, the application pops up then immediately closes. No error message.

It seems like the app is just closing before the main window can open. This is not a crash but a timing issue that has popped up in the past. I think we should use this opportunity to fix it once and for all if we can reproduce it reliably. Let me take a look and maybe prepare a bug fix build.

Same problem main windows pops up and then closes!

@funkyboogiemann you’re on Windows right?

That’s correct, windows 10

Thanks. Looking into it now.

Can you guys try 2.2b16 and report back?

hi, just checked your message, downloaded and ran new version, same issue (windows 10)

Ok and you can see the version number as 2.2b16, correct?

2.2B16 Still same issue.
Windows 10

Correct. With latest version installed today

Ok. Just posted 2.2b17 with one further tweak. This bug has been bugging (no pun intended) me for a while so I’m happy we should be able to eradicate it once and for all.

Hi tried again still the same, got a database reset warning first time but still not working sadly. Do we need to uninstall the previous version or does that make no difference??

2.2B17 Same issue. Still no error message. THe build from two weeks ago worked like magic. What changed?

Timing in the code changed. This bug only happens when some code execute faster than some other code. The app starts but the main window is not opened yet and so the app closes. If only I could reproduce it here it would take 3 seconds to fix but it’s been appearing and disappearing based on the changes I make in the code so it’s a pain to track down.

Will post another update in a bit. We will figure this out this today.

B17 Same issue!