2.2b10 Error Reading Traktor collection

Thanks for uploading this - I’m afraid I’m getting an error

When clicking on Traktor (3.2.1) I get the error message

Operation returned an error.

Hope this is easy to fix.


Thanks for the feedback. Remember to always open a new topic for new issues so that the beta announcement thread doesn’t become a mess.

Let me look into this.

I have the same problem on Traktor 3.3.0 and get the same error message.

Rekord Buddy also does not recognise any song in my collection in Rekordbox, but it does not give an error message for Rekordbox.

@Sasuketwr For rekordbox, Did you check the steps in the manual about viewing your rekordbox collection?


I receive ‘Operation returned an error’ when I try open the collection tracks folder from any version of Traktor 2 in Rekord buddy. I’m using Windows 10 on beta 2.2b11.

I normally use Traktor 2.6.8 and I tried the latest Traktor 2.11 (which I dislike to use).



@mharris17 I moved you post to the existing topic on the subject. It makes my life easier if people can post related issues in one thread.

I am looking into this and will check back here if I have questions for you guys or a fix.

Hi - confirming I am experiencing the same issue. Any time I try to open any Traktor collection that I have ever had from Traktor 2.11.0 through to 3.2.1.

Reproduction steps:

  1. Windows 10
  2. Open Rekordbuddy 2.2b11. Fresh install today.
  3. Click on the Triangle icon next to any Traktor instance to view the collection
  4. See “Operation returned an error” popup and I am unable to see any tracks or playlists from within any Traktor collection.

From Reproduction Step 3

From Reproduction Step 4

NOTE: Tracks within RekordBuddy and RekordBox display without issue. Only Traktor can’t display any tracks/playlists.
Tracks in RekordBuddy (from RekordBox)

Tracks in Rekordbox collection

Thank you - please let me know if there’s anything I can do to help you debug this. Much appreciated!

I have the exact same problem.

No matter which version of Traktor I try. I even copied the collection file to the desktop to see if that helps.

+1 chiming in to say I have the same issue. Everything from Serato loaded fine, but no version of Traktor is loading.

Can you guys zip up and DM me your Traktor collection.nml file so I can try and reroduce this here?

Hi, I have sent you a link to mine on dropbox in a DM. Good luck bud!

Thank you sir! Will try and repro here.

I have a fix. Will be posted in the next beta build probably tonight.


Where can I get the updated beta from? I can see no download links other than the email that I got when I purchased and that tells me it has expired (as does the product itself).

At the moment this product has zero use to me because it has to work on Windows with Traktor. It cannot do the one thing that I hoped it could.

All 2.2 betas updates are posted in the 2.2 beta thread. Windows doesn’t do automatic updates yet in the beta so you have to use the same link to download a new build.

As a side note, Windows is in BETA right now which means there is no expectation of what it can or can’t do at the moment. Beta users are there to help me find issues and get the app to ship as quickly as possible but it’s not something that’s meant to have other uses until it officially ships.

This topic was automatically closed after 333 days. New replies are no longer allowed.