2.1beta(645) unable to drag and drop XML files on a new installation

So I decided to give RB2.1 a try.
To do so, I decided to use my backup computer first, test and if everything works well, migrate my main computer.

So I installed directly the Beta 645 on my computer that never previously had any RB version on it. I entered my license number, and the app opened, with nothing in the screen (except for tags columns) although I have s Serato 2 Pro Library on this computer.

I tried to Drag & Drop my iTunes XML file fist to see if I could see my iTunes Library in RB, without success. When I try to D&D the xml file on the RB window, it would just not take it.

So I exported my Rekordbox Library to XML to try it, and I have the same result with I try to D&D my xml file.

I closed RB. Opened it again, tryed the same things again without success.

I deleted the Music/Rekord Buddy folder. Opened RB, entered the license number. Tried again. Nothing.

Rebooted the computer…. Etc etc. Nothing works.

My computer is a MacBook Air running 10.14.6. Rekordbox version is 5.7. Serato is 2.1.1.

I have to say that my music (and rekordbox library) (and iTunes Library) is on an microSD inserted in the SD slot with a BaseQi adapter. So it is considered like an external drive I suppose.

Oh! Since I tought that the « external drive » could be the problem, I created a new iTunes Library locally on my computer. And when I tried to D&D the xml file from that local iTunes library, I encountered the same problem.

Let’s try and take one thing at a time. I’m assuming RB means Rekord Buddy in your message (and not rekordbox for example).

When you say the first time you opened the app nothing was displayed, do you mean you didn’t even see a Rekord Buddy collection in the sidebar?

It’s odd that your Serato local collection is not found. Do you have a _Serato_ folder in your music folder?

Yes, sorry for confusion, RB means RekordBuddy !!

Here is a screen capture of what I get when I open RB !! Pretty “empty”!!!

I just installed the “stable version” 2.0.29

I then clicked the “import everything from Serato” and it imported everything without problem. So it seems that the stable version finds the Serato folder.

Then I clicked “import everything from rekordbox”, chose the xml file, and again, did the import without problem. So my xml file seems to be ok.

I just saw that you released a new version 646. Should I try it now or if you want to investigate a little more with 645 ?

Ok, so now, I decided to try beta 646 on my main machine with the same results.

My main machine is a macbook pro running 10.14.6
I have installed on it:

  • Serato 2.2.3
  • Traktor 2.11.3
  • rekordbox 5.7

and when I am using Rekord Buddy 2.0.22 to sync my libraries, it works without problem.

But when I start Beta 646, I see the same blank screen, without any library showing up and I cannot drag and drop any xml.

I’m also having this same problem and my screen looks the same as the screenshot in the above post.

Hope this can be fixed soon as I initially installed Rekord Buddy 2.0.29(569) with it linked to Traktor 3.2 though realised my Traktor 3.2 is a demo version and therefore wanted to it to link to my full version of Traktor (2.11.2 11). I then deleted Traktor 3.2 however 2.0.29 has not recognised this and I saw in another post that you can only change which Traktor version Rekord Buddy recognises in Beta hence my current problems.

This looks to be a timing issue that I have to try and reproduce here in order to fix it.

I may have some more more questions for your guys in order to help me investigate.

All good, would be glad to help out if that can contribute to getting the problem fixed .

So I updated both my MacBook Pro and Air with beta 647 with still the same problem.

I also installed Stable 2.0.29 on both machine, and upgraded Traktor to 3.2 and it seems to be working importing from rekordbox to both Serato and Traktor 3.2.

Although I didn’t have Traktor on my macbook air, so I started from scratch when exporting to traktor 3.2 and it found more that 1000 error of files without or with more that 1 BPM (or something like that, I don’t remember exactly the exact error), but it is probably due to something completely different than the problem we are having with the blank window.

So this is it for now. Any question you might have, I will be glad to answer so that we can help you solve that problem. Cheers!

First question, can you confirm that you get the blank window with the latest beta (647) and not an older version?

Just confirmed that my version is (647). I’ve attached a screenshot below of what I see when I open Rekord Buddy if that helps.

Also to confirm, I presume you mean to drag the xml. file to the window on the left side (the one that doesn’t have the columns such as “#”, “Title” etc.)?

Yes I confirm, I have 647 on both my laptop with same issue.

Don’t worry about the XML just yet, the current state of the app won’t allow any of this to work correctly.

Next check, can you guys delete the Rekord Buddy folder in your Music folder and launch the app? You’ll need to re-enter your license key but this will make sure that this is reproducible for you from a clean library.

Sorry to have you do all this but since I can’t repro the problem myself, I need the help.

Did that… same problem … it didn’t solve the problem :frowning_face:

No problems. This is all part of rulling out potential causes so this helps. I’ll be back with more questions.

1 Like

Deleting the Rekord Buddy folder in my Music folder gave me a clean library and told me to change my preferences that you see from first installing the program though after adding the XML and exporting to Traktor again it still didn’t work.

I believe this is because Rekord Buddy still thinks that my latest version of Traktor is 3.2 even though I uninstalled that version of Traktor.

Is there anything I can delete/change to make Rekord Buddy recognise Traktor 2.11.2 11 as the correct/only version of Traktor I now have (and not Traktor 3.2)? Apparently you can do this in the Beta though after installing the Beta again I couldn’t see how this was done nor could I see what version of Traktor it thought I had (though I assume it still thinks my latest Traktor version is 3.2).

Just thinking. Maybe we could try earlier beta version to see it the problem was there right after 2.0.29, or if it was introduced along the way?

2.0 and 2.1 are completely different codebases so issues in one won’t be related to issues in the other unfortunately. I’m working on a build that will give us more information as to what is going on for you guys.

@mike.newman023 if you want to delete the Traktor 3.2 you can just delete that folder from your Documents/Native isntruments folder. I recommend using the latest build of Traktor though as it is the officially supported one for Rekord Buddy.

Can you guys update to the latest (648) build and launch the app from a terminal window?

Open a Terminal and type /Applications/Rekord\ Buddy\ 2.app/Contents/MacOS/Rekord\ Buddy\ 2

then give me the terminal output after you launch the app in a DM.


I just did that and sent you the output. But now, something seems to work! look at my screen capture!! But drag and drop XML still doesn’t !